MaidCentral - Some QuickBooks customers were missing for some companies – Incident details

All systems operational

Some QuickBooks customers were missing for some companies

Resolved
Degraded performance
Started 28 days agoLasted 1 day

Affected

MaidCentral Web

Degraded performance from 6:30 PM to 3:00 AM

Updates
  • Resolved
    Resolved
    We identified an issue where some of your customers from QuickBooks Online were not appearing in your account. QuickBooks sends us your customer list in batches. In certain cases, QuickBooks returned a batch that was smaller than the size it was asked for — an unexpected behavior on QuickBooks’ side. Because that short batch signaled there was no more data to send, the remaining customers weren’t pulled in during that sync. This only affected accounts with a large number of QuickBooks customers, and only when QuickBooks returned one of these unexpectedly short batches. Many partners were never affected. We’ve since strengthened how our integration handles QuickBooks’ batching so this can’t happen again.
  • Investigating
    Investigating
    We are investigating reports that some customers imported from QuickBooks are not appearing in customer lists for some companies.