MaidCentral - MaidCentral was slow for about an hour – Incident details

All systems operational

MaidCentral was slow for about an hour

Resolved
Degraded performance
Started about 1 month agoLasted about 1 hour

Affected

MaidCentral Web

Degraded performance from 7:37 PM to 8:35 PM

Updates
  • Resolved
    Resolved
    Resolved around 4:35 PM ET the same day. We replaced the maintenance task with a lighter nightly version that is hard-capped so it cannot run into business hours again. No customer data was affected.
  • Identified
    Identified
    MaidCentral pages loaded slowly or timed out starting around 3:37 PM ET. A behind-the-scenes maintenance task overran into business hours and crowded out customer work.